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Tech Notes

 

Description:

On Send of an email message, Outlook intermittently selects a recipient from the KI Systems Address Book.


Number:100-00087
Category:Client
Product:All Products
Created:5/14/2003
Last Modified: 7/8/2005

Issue/Symptom:

If the To, CC or BCC field of an email message contains an ambiguous entry (i.e. "an") and the entry has not been resolved at the time the "Send" button is pressed, Outlook will attempt to resolve the name to the match found in the search list of available Address Books.

If match's are found in Outlook Contacts or Global Exchange List (GAL) the user is presented with the Check Names resolution screen. If no matches are found in Outlook Contacts or the GAL, Outlook will search the KI Systems Address Book and select the first potential record match.

Once a single match is found Outlook selects the recipient information and sends the message. The user is not provided the opportunity to verify the recipients name/address. This behavior may result in email messages being mis-directed to recipients found in the KI Systems Address Book.

Error Message:

None

Cause:

The Check Names feature of Outlook does not support Ambiguous
Name Resolution (ANR) for 3rd Party MAPI products.

Please see Microsoft's Knowledge Base Article 321181

http://microsoft.com.
default.aspx?scid=kb;en-us;321181

By design, on Send of an email message, the Check Names feature of Outlook is invoked. The Check Names utility runs against all available address lists. If no matches are found in the first address list, Check Names will search the each available list until a match is found. As soon as the Check Names utility finds a match, the search is considered complete and the utility ends its search.

Resolution:

Option 1:  Download MAPI SR-1 and upgrade the workstation.  MAPI SR-1 provides support for Ambiguous Name Resolution (ANR) with Microsoft Outlook 2000/2002.

NOTE: MAPI SR-1 is compatible with KI Systems Office Automation Tools for Office XP.  Customers using KI Systems Office 2000 or Office 97 version products should not install MAPI SR-1.  Please refer to Option 2 below.  

Option 2: Remove KI Systems Address Book from the List of available books to search.
  • Open Outlook
  • On the Tools menu, click Address Book.

  • On the Tools menu of the Address Book dialog box, click Options.

  • Under When sending mail, check names using these address lists in the following order.
  • You will probably see the following books listed: GAL, Contacts (Outlook) and depending on our setup installation options either "Employee List" or "Firm Email Contacts".
  • Click the KI Address Book container name "Employee List" or "Firm Email Contacts" and click Remove.
  • Close and restart Outlook.

    Removing KI Systems Address Book from the List of available books to search will allow users to access contact and email addresses from the KI Address Book and will prevent the automatic lookup/completion of names.


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